sudoBash418
  • Joined on Dec 12, 2018
Loading Heatmap…

sudoBash418 commented on issue cromer/pamac-classic#3

Build error with vala 0.48

> BTW if I install vala 0.46 manually and then update pacman-classic, pacman-classic still offers me to upgrade vala to 0.48, which it shouldn't or should? I'm confused Yes, it should offer to upgrade vala, just as `pacman -Syu` would. The `pamac-classic` package has a *build-time* dependency on the vala package, not a *runtime* dependency; the difference being that after the `pamac-classic` package is built, it doesn't need `vala` to be installed at all to run. In other words, the only time `pamac-classic` requires `vala<0.48` is when installing/updating `pamac-classic` itself. If you allow vala to be updated, it shouldn't cause any issues aside from not being able to install/update `pamac-classic` until the fix for this issue is released.

5 months ago

sudoBash418 opened issue cromer/pamac-classic#3

Build error with vala 0.48

5 months ago