Graphical package manager for pacman based on pamac 5.x.x
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

meson.build 3.7KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. cfg_pamac_classic = configuration_data()
  2. cfg_pamac_classic.set('DATADIR', join_paths(get_option('prefix'),get_option('datadir')))
  3. cfg_pamac_classic.set('PKGDATADIR', join_paths(get_option('prefix'),get_option('datadir'),'pamac'))
  4. cfg_pamac_classic.set('GETTEXT_PACKAGE', 'pamac')
  5. cfg_pamac_classic.set('RELEASE_NAME', 'pamac')
  6. cfg_pamac_classic.set('PREFIX', get_option('prefix'))
  7. cfg_pamac_classic.set('VERSION', '6.7.0')
  8. cfg_pamac_classic.set('TESTSRCDIR', meson.source_root())
  9. cfgfile_1 = configure_file(input: 'Config.vala.base',output: 'Config.vala',configuration: cfg_pamac_classic)
  10. pamac_classic_deps = [gdk_3_0_dep]
  11. pamac_classic_deps += [gtk_3_0_dep]
  12. pamac_classic_deps += [json_glib_1_0_dep]
  13. pamac_classic_deps += [libalpm_dep]
  14. pamac_classic_deps += [libnotify_dep]
  15. pamac_classic_deps += [libsoup_2_4_dep]
  16. pamac_classic_deps += [vte_2_91_dep]
  17. pamac_classic_deps += [gio_2_0_dep]
  18. pamac_classic_deps += [glib_2_0_dep]
  19. pamac_classic_deps += [gobject_2_0_dep]
  20. pamac_classic_sources = [cfgfile_1]
  21. if not DISABLE_AUR
  22. pamac_classic_sources += ['aur.vala']
  23. endif
  24. pamac_classic_sources += ['alpm_config.vala']
  25. pamac_classic_sources += ['choose_ignorepkgs_dialog.vala']
  26. pamac_classic_sources += ['choose_provider_dialog.vala']
  27. pamac_classic_sources += ['common.vala']
  28. pamac_classic_sources += ['mirrors_config.vala']
  29. pamac_classic_sources += ['package.vala']
  30. pamac_classic_sources += ['pamac_config.vala']
  31. pamac_classic_sources += ['preferences_dialog.vala']
  32. pamac_classic_sources += ['progress_box.vala']
  33. pamac_classic_sources += ['transaction.vala']
  34. pamac_classic_sources += ['transaction_sum_dialog.vala']
  35. pamac_classic_sources += [pamac_transaction_gresource_xml_file_c]
  36. pamac_classic_vala_args = ['--pkg','posix']
  37. pamac_classic_vala_args += ['--vapidir='+join_paths(meson.source_root(),'src/vapis')]
  38. pamac_classic_vala_args += ['--gresources='+join_paths(meson.source_root(),'data/pamac.transaction.gresource.xml')]
  39. pamac_classic_c_args = []
  40. if ENABLE_UPDATE_ICON
  41. pamac_classic_vala_args += ['-D', 'ENABLE_UPDATE_ICON']
  42. pamac_classic_c_args += ['-DENABLE_UPDATE_ICON']
  43. endif
  44. if ENABLE_HAMBURGER
  45. pamac_classic_vala_args += ['-D', 'ENABLE_HAMBURGER']
  46. pamac_classic_c_args += ['-DENABLE_HAMBURGER']
  47. endif
  48. if KDE_TRAY
  49. pamac_classic_vala_args += ['-D', 'KDE_TRAY']
  50. pamac_classic_c_args += ['-DKDE_TRAY']
  51. endif
  52. if DISABLE_AUR
  53. pamac_classic_vala_args += ['-D', 'DISABLE_AUR']
  54. pamac_classic_c_args += ['-DDISABLE_AUR']
  55. endif
  56. pamac_classic_deps += [meson.get_compiler('c').find_library('m', required : false)]
  57. pamac_classic_link_args = ['-rdynamic']
  58. pamac_classic_vala_args += ['--gir=pamacclassic-6.0.gir']
  59. pamacclassic_library = shared_library('pamacclassic',pamac_classic_sources,dependencies: pamac_classic_deps,vala_args: pamac_classic_vala_args,c_args: pamac_classic_c_args,link_args: pamac_classic_link_args,version: '6.7.0',soversion: '6',install: true)
  60. pamac_classic_requires = []
  61. pamac_classic_requires += ['gdk-3.0']
  62. pamac_classic_requires += ['gtk+-3.0']
  63. pamac_classic_requires += ['json-glib-1.0']
  64. pamac_classic_requires += ['libalpm']
  65. pamac_classic_requires += ['libnotify']
  66. pamac_classic_requires += ['libsoup-2.4']
  67. pamac_classic_requires += ['vte-2.91']
  68. pamac_classic_requires += ['gio-2.0']
  69. pamac_classic_requires += ['glib-2.0']
  70. pamac_classic_requires += ['gobject-2.0']
  71. pkg_mod = import('pkgconfig')
  72. pkg_mod.generate(libraries : pamacclassic_library,
  73. version : '6.7.0',
  74. name : 'pamacclassic',
  75. filebase : 'pamacclassic',
  76. description : 'pamacclassic',
  77. requires : pamac_classic_requires)
  78. install_data(join_paths(meson.current_source_dir(),'pamacclassic.deps'),install_dir: join_paths(get_option('prefix'),'share','vala','vapi'))
  79. meson.add_install_script(join_paths(meson.source_root(),'meson_scripts','install_library.sh'),'src','pamacclassic','pamacclassic-6.0.gir')